Back to overview
Downtime

Minecraft server outage

Feb 28 at 01:00pm GMT
Affected services
Minecraft Paper Update

Resolved
Mar 01 at 01:00pm GMT

All services now operational, have fun crafting!

Updated
Mar 01 at 09:00am GMT

The Minecraft server outage has now been troubleshooted and appropriate fixes put in place. Please expect minor connection issues while the services get back up and running

Created
Feb 28 at 01:00pm GMT

Due to a router configuration error the following servers are offline. A fix will be implemented as soon as the internet connection is re-established and the servers tunnels reconfigured